Câu hỏi Làm thế nào tôi có thể làm cho người dùng gõ cú pháp C # làm nổi bật trong VS 2012 RC?


Bằng cách nào đó một phần cú pháp của tôi làm nổi bật cho mã C # đã biến mất trong IDE VS 2012. Gỡ cài đặt, khởi động lại và cài đặt lại không làm gì cả, cũng như không đặt lại màu trong hộp thoại tùy chọn.

Dưới đây là một số ví dụ về các mục xuất hiện mặc định (màu đen) thường có màu không:

  • Thuộc tính
  • Các lớp hệ thống
  • Lớp học của riêng tôi

Và đây là một số từ khóa vẫn có màu:

  • sử dụng
  • công cộng
  • khoảng trống
  • var
  • cho

Có ai khác có kinh nghiệm này và quản lý để sửa chữa nó?


76
2018-06-10 16:27


gốc


Xem cài đặt màu cho 'Loại người dùng'. - leppie
Hmm - Tôi chỉ thấy Kiểu người dùng C ++ và VB trong hộp danh sách "Hiển thị các mục" trong tùy chọn Phông chữ và Màu sắc. Trên thực tế tôi không thấy bất kỳ C # -specific mục nào cả. Có lẽ có điều gì đó sai ở đó? Mặc dù việc gỡ cài đặt hoàn tất và cài đặt lại đã được khắc phục ... - Jedidja
Tôi cũng không thấy "Loại người dùng" trong "Công cụ" → "Tùy chọn" → "Môi trường" → "Phông chữ và màu sắc" → "Mục hiển thị:". Giải pháp của câu trả lời được chấp nhận đã không làm điều đó cho tôi. Cuối cùng tôi đã thử các công thức từ Leonardo Herrero dưới đây, xóa các công cụ từ thư mục AppData. Nó đã làm việc. Bây giờ tôi thấy tùy chọn "Loại người dùng" và các lớp và cấu trúc được tô màu trong trình chỉnh sửa. - Jeppe Stig Nielsen


Các câu trả lời:


Đây là một giải pháp đơn giản. Chuyển đến thư mục nơi devenv là (cho 2012 RC) và loại devenv.exe /setup. Nó sẽ khắc phục vấn đề của bạn.

devenv.exe thường là một cái gì đó như C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE.

Chỉnh sửa: Nó đã được gợi ý rằng bạn làm điều này từ dấu nhắc lệnh Visual Studio (Bắt đầu> Microsoft Visual Studio> Công cụ> Visual Studio Command Prompt), và / hoặc đảm bảo dấu nhắc lệnh của bạn có quyền quản trị viên.

Lưu ý cho những người khác: Điều này có một cơ hội rất tốt làm việc cho nhiều phiên bản khác của Visual Studio, bao gồm 2008, 2010, 11 beta, ...


99
2018-06-12 20:03



Cảm ơn bạn!! :) Điều đó làm việc (và những người nghĩ rằng mất màu sắc sẽ rất khó chịu). Lưu ý cho bất cứ ai khác mà bạn phải chạy dấu nhắc lệnh như quản trị viên khác. - Jedidja
1, điều này đã không làm việc cho tôi lần đầu tiên từ một Command Prompt tiêu chuẩn, nhưng sau đó chạy nó từ một dấu nhắc lệnh VS đã làm việc một điều trị, cảm ơn :) - Town
Cảm ơn các đầu vào. Tôi đã cập nhật câu trả lời. - GregRos
Điều này không hiệu quả với tôi. Gỡ cài đặt 2012RC Web Express đã làm :) stackoverflow.com/questions/12197771/… - ysrb
1 cho điều này làm việc nhưng tôi vẫn không nhìn thấy các đối tượng của tôi màu ..... cập nhật phải mất một vài phút cho các đối tượng được màu xanh nhạt. - Bill Blankenship


Vấn đề của tôi bị giới hạn khi loại "DateTime" không hiển thị bằng màu xanh dương nhạt như các tên lớp khác. Tôi đã sửa nó bằng cách đơn giản chuyển đổi qua lại giữa VS Themes. Được phát hiện do tai nạn. Nhanh hơn nhiều so với cài đặt đặt lại hoặc cài đặt sửa chữa ...

Công cụ menu VS -> Thay đổi chủ đề màu


31
2018-01-08 18:32



Đây là một câu trả lời tuyệt vời cho vấn đề của tôi, đó cũng là màu của "DateTime". Đã sửa! Cảm ơn. - Nelson Reis
Cố định cho tôi, cảm ơn - AlexFoxGill
Điều này cũng cố định nó cho tôi. Cảm ơn! - JMS10
Đã làm việc! Cảm ơn rất nhiều. - Henk Mollema
Tôi đã cài đặt các công cụ điện và nó sẽ mất màu sau khi khởi động lại VS. Đây là bản sửa lỗi cố định: stackoverflow.com/a/14297776/78739 - JMS10


Đây là những gì làm việc cho tôi:

1 - delete all in C:\Users\userNAme\AppData\Roaming\Microsoft\VisualStudio\11.0
2 - open vs console as administrator, and run:
      devenv.exe /setup
      devenv.exe /ResetSettings

Thao tác này sẽ đặt lại tất cả cài đặt môi trường của bạn.


30
2018-01-02 15:48



Điều này giải quyết các vấn đề đối với tôi. Tôi đã có trước đó đã có một phiên bản dùng thử miễn phí của Visual Studio 2012 Ultimate (tôi nghĩ) nhưng bây giờ đã chuyển sang Visual Studio 2012 Professional (trên một giấy phép trả tiền). Tôi specualte rằng một số "thùng rác" từ phiên bản VS2012 trước đó vẫn còn lại trong thư mục AppData ở trên. - Jeppe Stig Nielsen
Đó là điều duy nhất làm việc cho tôi. Nhiều đánh giá cao! - Warren Rox
Đây là những gì làm việc cho tôi, là tốt. Tôi nghi ngờ tôi là một vấn đề Resharper được chuyển sang một máy mới. Tôi nhận được các tập tin dự án trở lại từ kiểm soát nguồn, nhưng nhận thấy rằng tất cả các cú pháp tô sáng của tôi đã biến mất. Đặt lại tất cả các cài đặt không hoạt động đối với tôi (thông qua GUI) - và chỉ thực hiện ba bước này cuối cùng cũng đã bắt đầu hoạt động tốt trở lại. Cảm ơn. - Jason
Điều này làm việc cho tôi. - Jonathan Kittell
Điều này làm việc cho tôi. Tôi đã thử chỉ bằng cách sử dụng / thiết lập đầu tiên, mà không làm việc. Nhưng khi tôi đã làm / ResetSettings nó cuối cùng đã làm việc. Cảm ơn. - Mike


Nếu không có cách nào ở trên phù hợp với bạn, hãy xóa tất cả các thư mục có tên GUID trong khóa đăng ký này (hãy đảm bảo rằng phiên bản Visual Studio của bạn đã đóng):

Nếu bạn đang sử dụng Visual Studio 2012: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\FontAndColors

Nếu bạn đang sử dụng Visual Studio 2013: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0\FontAndColors

Nếu bạn đang sử dụng Visual Studio 2015: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0\FontAndColors

Khởi động lại Visual Studio, và bạn sẽ thấy một vài "User Types" khác nhau để cấu hình. Sau đó, bạn có thể nhập Phông chữ và Màu sắc mà bạn đã sao lưu và mọi thứ sẽ tốt để thực hiện. Điều này cũng có thể làm việc cho các phiên bản trước đó và trong tương lai của VS, nhưng tôi chưa thử nghiệm.

Tuyên bố từ chối trách nhiệm: Đảm bảo bạn xuất / sao lưu cài đặt Phông chữ và Màu sắc hiện tại của mình trước khi thực hiện các điều chỉnh đăng ký này. Tôi không thể chịu trách nhiệm cho bạn mất cấu hình của bạn :)


11
2017-09-11 19:13



Tôi đã gặp vấn đề tương tự và nhận thấy tôi không có phím FontAndColors. Tôi tạo ra nó, mở lại VS và lo và nhìn! Có màu sắc !! Nhưng, khi tôi gỡ bỏ chìa khóa một lần nữa, màu sắc vẫn ... - Peter
tuyệt vời, điều này và điều này một mình làm việc cho tôi :) - Manish Mishra
Không phải là một quản trị viên trên máy tính của tôi, điều này làm việc cho tôi. Cảm ơn! - ssn


Nếu bạn vẫn gặp sự cố này, hãy thử ResetSettings (đã làm việc cho tôi)

LƯU Ý: điều này sẽ thiết lập lại các cài đặt Visual Studio 2012 :)

1) gần so với

2) mở cmd (với tư cách quản trị viên).

3) vào thư mục devnev.exe (giống như "C: \ Program Files (x86) \ Microsoft Visual Studio 11.0 \ Common7 \ IDE").

4) nhập "devnev.exe / ResetSettings"

5) mở vs và nhìn vào màu sắc đẹp


9
2017-12-10 16:14



Điều này làm việc cho tôi. Cảm ơn bạn - Eduardo Brites


Tìm thấy nguồn gốc của vấn đề: Nếu bạn có "Năng suất công cụ 2012" Cài đặt,

bạn nên đi đến Công cụ -> Tùy chọn -> Năng suất công cụvà tắt "Trợ giúp tham số được tô màu" Tùy chọn.

Điều này cố định cú pháp làm nổi bật vấn đề.


8
2018-04-03 09:33



Cũng được mô tả trong stackoverflow.com/questions/14253879/… - Shaun Wilson
Bài viết đó nói về thuộc tính Màu sắc ... Dù sao, tôi đoán rằng tùy chọn Power Tools gây ra nhiều vấn đề. - Nir Kornfeld


Nếu ai đó gặp vấn đề tương tự Visual Studio 2013 như tôi đã làm, giải pháp duy nhất làm việc cho tôi là lần đầu tiên đóng VS2013 và sau đó xóa khóa đăng ký sau:

HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0\FontAndColors

Sau khi mở lại VS2013, cú pháp tô sáng của tôi cho các kiểu đã được khôi phục.

Trước khi xóa khoá đăng ký, tôi nhận thấy rằng tất cả cài đặt "Kiểu người dùng ..." trong phần Phông chữ và Màu sắc của Công cụ> Tùy chọn bị thiếu. Xóa khóa đăng ký đã khôi phục chúng. Họ đã đạt được các giá trị mặc định của họ đã cho tôi cú pháp tô sáng màu sắc mà tôi đang tìm kiếm.

Đây là giải pháp duy nhất có hiệu quả đối với tôi. Chuyển đổi chủ đề, đặt lại cài đặt được cá nhân hóa của tôi thành mặc định, chạy devenv.exe với các công tắc dòng lệnh khác nhau để thiết lập / đặt lại Visual Studio không hoạt động.

Tôi cũng đã tạo báo cáo lỗi sau với Microsoft trên trang Kết nối của họ:

http://connect.microsoft.com/VisualStudio/feedback/details/810985/incorrect-syntax-highlighting-for-c-types.


7
2017-12-09 16:02



Cứu Chúa! Cảm ơn. - KingCronus


Đối với tôi "Năng suất công cụ điện 2012" là nguyên nhân. Không có gì được đề nghị ở đây đã giúp. Sau khi loại bỏ các công cụ quyền lực màu sắc đã trở lại.


4
2018-02-05 13:16



Tương tự trong trường hợp của tôi. Không có gì giúp được. Tuy nhiên, việc gỡ cài đặt Productivity Power Tools từ VS 2012 đã thực hiện thủ thuật. - Ganesh R.


tôi đã làm tất cả các những thứ được liệt kê ở đây và vẫn không có gì (Bản cập nhật VS2013 3). Tôi đã thử / thiết lập, / resetsettings, xóa các công cụ trong AppData, xóa các khóa registry. Tuy nhiên, loại người dùng sẽ không được đánh dấu ngay cả trong bảng màu mặc định.

Điều gì đã giúp cuối cùng là mở hộp thoại Fonts and Colors, chọn Identifier và làm cho nó Bold. Sau đó loại bỏ Bold. Sửa lỗi tức thì!


2
2017-11-25 18:14





Tôi đã có cùng một vấn đề .... chỉ cần gỡ bỏ cài đặt và cài đặt lại một mình đã không sửa vấn đề. Sau khi tôi chưa cài đặt, xóa tất cả phần còn lại của VS 2012 trong các tệp chương trình, xóa tất cả khóa đăng ký có liên quan và xóa thư mục VS 2012 khỏi Tài liệu của tôi, sau đó cài đặt lại, loại người dùng hiển thị trong các mục hiển thị trong phông chữ và màu sắc mọi thứ trở lại bình thường. Đoán của tôi là nó là một vấn đề với một hoặc nhiều khóa registry nhưng tôi không thể chắc chắn về điều đó.


0
2018-06-12 20:00





exit devenv

đi đến đường dẫn bên dưới hkey_current_user \ software \ microsoft \ visualstudio!

xóa 9.0, 10.0, 10.0_config (tôi muốn nói tất cả các thư mục khác ngoại trừ 11.0 và 11.0_config)

Bây giờ bắt đầu devenv và xem các màu huyền diệu trở lại bình thường


0
2017-10-10 19:01



Xin vui lòng không SHOUT tại chúng tôi. Sẽ rất hữu ích nếu bạn chỉnh sửa câu trả lời của mình để chỉ giữ các mũ cần thiết, chẳng hạn như đối với HKEY_CURRENT_USER. - Code-Apprentice
uuuuuhhhhhh, hồi tưởng lại những năm 80! - nalply
Tôi muốn upvote câu trả lời này bởi vì nó đã dẫn tôi đến giải pháp (một khóa registry VS11 bị hỏng, ngoài các phím 11.0 và 11.0_config thông thường) nếu nó chỉ rõ ràng hơn một chút. - Dave